BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Just replaced battery on '08 1200S - have done this a few times before with no problem and bike was running great before..

Removed old battery
installed new one
key on
roll throttle to full hold for a second or two then back to idle - I do this 3 times
key OFF
wait for screen to go blank
key back ON
Start the bike....

It starts fine and goes to FULL THROTTLE!!!!!!

Turn bike off...

I tried leaving the battery disconnected for a while and try again = same issue....

never had this before and heard of guys having low idle issues after battery replace but not full throttle... WTF?

anyone else have an idea? or seen this?

Thanks
 

·
Registered
Joined
·
82 Posts
Can you hear the stepper motor move when you roll the throttle?
And how fast are you moving the throttle? Gradually or fast?

There has been cases where the cable attach at the throttle has snapped and jammed the throttle open..... usually happens when the cable has been tightened too much and the rider has twisted the throttle to fully open
 

·
Registered
Joined
·
41 Posts
You sure?

You sure that throttle cable hasn't jammed wide open? Seem to remember that these bikes don't have a throttle return cable . . .
 

·
Registered
2009 K1300S, 2017 S1000R
Joined
·
317 Posts
I think you need to remove the fuel tank and trace out the throttle lines to the fuel rack. Then look things over while you roll the throttle. You may have a broken cable as previously mentioned. If you can't see under the air box it too may have to come out. First time is a serious hassle.
 

·
Registered
Joined
·
71 Posts
My BMW dealer says no calibration is required when you change the battery. I installed a new battery in my 2008 K1200S recently and had no issues.
 
1 - 5 of 5 Posts
Top