BMW K1200, K1300, and K1600 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Th odometer and trip meter on my 1985K100RS recently stopped working. I have owned this bike since new. Is there anything that I can test/fix/replace to see what the issue is, or does the unit need to be swapped out completely? The speedometer still functions fine. Not like the old days with mechanical units...
 

·
Registered
Joined
·
196 Posts
  • Like
Reactions: Beech

·
Registered
Joined
·
161 Posts
If you're handy and patient (and one has to be with BMW bikes) you can fix it yourself.

All the early- to mid-1980s BMWs (cars included) had odometer gears that turned to cheese, you can crumble them between your fingers. I think the lubricant permeated the gears to cause this, but it's water under the bridge.

The solution is to get better gears. Gears aren't expensive and I've gotten mine from odometergears.com and been happy. IIRC they use acetyl copolymer. You didn't need to know that, just tossed it in for amusement. I are engineer. Make sure you know the correct gears to get - this might mean disassembly before ordering. Your bike will run just fine without the cluster, did you look at the speedo anyway?

There is more than one gear in there - from memory there are four (?). Although all might not have crumbled, probably best to do all at once. Disassembly of the cluster is not difficult nor does it require special tools other than the aforementioned patience and a bit of elbow grease. You should seal the glass to the cluster enclosure when you button it up so that if it rains, water won't enter the cluster via the joint between the tow.

How do I know...? Multiple cluster surgeries with my two '85 K100RS bikes, both now gone. A 10 mm combination wrench to remove the cluster, allen wrench (forgot the size), and small screwdriver are needed to disassemble.
 
1 - 4 of 4 Posts
Top