BMW K1200, K1300, and K1600 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Has anyone had any problems with a 1990 k75, when I turn the ignition switch on all the instrument lights come on and then I press on the electric start button the instrument lights dim and the bike will not start. I've checked and charged the battery and the battery is good. this is an intermittent problem. I've jumped the the motorcycle and it starts right up with not problem, and then a couple or a few days later I'll have the same problem. trying to save money, any suggestions? could I have a short on the ground side? or can the starter relay cause something like this? I know usually the starter relay would get stuck and continue to run is the common problem for the starter relay.

Thanks
 

·
Registered
Joined
·
350 Posts
Relay

Open the relay box and tap the relay with the screwdriver handle when this happens next. If it then starts right up, replace the relay - I believe these are common and available at a local auto parts store.
 

·
Registered
Joined
·
1,256 Posts
I had a situation similar to this with the 87 I used to own, ended up being the ignition switch (the electrical part under the part your key goes in).
Gilly
 

·
Registered
Joined
·
163 Posts
aflores739 said:
Has anyone had any problems with a 1990 k75, when I turn the ignition switch on all the instrument lights come on and then I press on the electric start button the instrument lights dim and the bike will not start. I've checked and charged the battery and the battery is good. this is an intermittent problem. I've jumped the the motorcycle and it starts right up with not problem, and then a couple or a few days later I'll have the same problem. trying to save money, any suggestions? could I have a short on the ground side? or can the starter relay cause something like this? I know usually the starter relay would get stuck and continue to run is the common problem for the starter relay.

Thanks
I'm relatively new to the K-Bike community but I read that the starters on these motorcycles need regular cleaning to prevent problems. I did mine while replacing all the fluids and found it quite dirty.

Check out this document:

http://www.bmwmcnj.com/Technical/bmd k100 how to tips for free..pdf

Nick
78 R100S
91 R100RT
93 K75S
 

·
Registered
Joined
·
21 Posts
When I had similar problems with my K100 I was advised that the starter motor brushes were a likely culprit. It took me 45 minutes from start to finish and the problem was instantly cured.
 
1 - 6 of 6 Posts
Top