BMW K1200, K1300, and K1600 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Currently running PR4s @ 3-4K miles and today the bike at low speed feels like wobble wobble - doesn't want to go straight :surprise
 

·
Registered
Joined
·
9 Posts
Hmmmm...I've heard very few complaints about PR4's on the KGT's. Could this be a problem with worn ball joints? What's your milage?
 

·
Registered
Joined
·
22 Posts
I've been running PR4GT's for the past 3 sets and typically get between 10-12K out of the rear and the front could go a little longer, but I always change them out together...
 

·
Registered
Joined
·
68 Posts
I've got 51K on my GT. The front and rear shock(s) aren't in pristine condition in my limited experience. I think my front ball joints are still in nominal shape, but I do have warbled front tire wear. I attribute that to the shocks (leaking a bit).

Pirellis front and rear. Something Dragon on the rear fwiw. Until I change out the shocks, if I change tires they'll be something cheap like Shinkos. Otherwise, the front IMO causes a little wandering under 5-10 mph.
 

·
Registered
Joined
·
68 Posts
Worst tires?

The meatball who owned my bike must of been into to saving money, or he was an idiot. I'll go with idiot.

The tires, front anyway is wearing like crap because this knothead put BELTED tires on this thing. What an A-hole.

The ride leaves a lot to be desired as well.

The tires are supposed to be radials. Ghod what a moron.
 

·
Registered
Joined
·
677 Posts
Not likely its your tires. Check the suspension for wear.
 
1 - 8 of 8 Posts
Top