BMW K1200, K1300, and K1600 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello all ....
A short introduction from myself :) ..
After many years of sports bikes and getting a knackered wrist I have recently purchased a mint 05 k1200s ... Not quite as in your face as a 2nd gen Buda I had but will give it a run for its money .
Anyway ... After looking through the forums I'm at a small loss to my rough idle ...
It ticks over @ just over 1000rpm then dips to about 900 every few seconds when warm .. when riding below 3k there was a slight vibration from rough running but pulls like a train with no issues to redline.
I pulled the air box out and used wet n dry to free up the idle control valve ect did a tps reset and would say it's 80% better but still irritating lol ... I'm now thinking plugs or coil pack ? But I guess the problem would persist through the revs ?
Cheers guys
 

·
Registered
Joined
·
68 Posts
The factory wants the plugs changed every 12K miles. Mine doesn't run silky smooth either and I have the fairings off for repair and will probably put a new set of plugs in. My friend says by hook or crook the cooling system "shouldn't need disturbed. But I haven't given the situation a good look-see.
 

·
Registered
Joined
·
23 Posts
I've got a R sport and the fueling is a little jumpy at idle and low RPM's but not enough to worry about. I changed the plugs and went through the whole radiator thing for a little improvement. You don't want to have to pay for the coil packs!
 

·
Registered
Joined
·
16 Posts
06k1200gt

Mine does the same dang thing. Above 90 degrees it does the goofy idle and the bucking-bronco thing where it hesitates on a full throttle. I put 93 octane in it, and it seems to help. The stupid thing is designed to run at the very leanest it can be. Emissions laws! We have these dumb laws for those who ride and drive, but, if we go to sea, after 12 miles out, all tankers use a cheap, cheap diesel and you should see the bellowing cloud of pollution the comes out. What a joke the EPA is.
 

·
Registered
Joined
·
8 Posts
Only 98 for me too. If I could fill with AvGas I'd do that, best octane you can afford basically if you ride with spirit but if you take it slow lower octane ok.
 

·
Registered
Joined
·
25 Posts
any news? I didn't even think it would be weather related, but my 07 is doing the same thing... 65-80mph all the way to work, and then it chokes and almost (or does) DIES at the security gate... I was thinking since it only had 3000 miles on it when I bought it last year, maybe there was some crap caught in the net in the gas tank and I freed it up and was choking it out there. A friend also mentioned I should check the fuel pump... hoping to find something here in the forums to lead me to the light.
 
1 - 9 of 9 Posts
Top