BMW K1200, K1300, and K1600 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
How many of you folks out there have replaced your oem battery and what was your replacement choice?My 07 is showing signs its time to replace it,thanks :)
 

·
Registered
Joined
·
650 Posts
Wht signs?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
Slow turn over when temps above 90f. I think a AGM should have been used in the first place. :boom:
 

·
Registered
Joined
·
1,658 Posts
Odyssey PC-680MJ

I think you'll find it to be the general consensus around here and for good reason. Google it. You'll find plenty of places to buy it.
 

·
Premium Member
Joined
·
2,680 Posts
Mine at one-year started to do the slow-crank/hesitant stuff. Got worse once it heated up and often had to hit the starter button a few times. I finally caved in and bought the PCM680MJ.

No problems since the new battery. I got mine from a local car battery shop for about $120. Cranks like lightening struck it now. :clap:

I had an old R1100RT bought in 1996. Installed 3 normal batteries in it (BMW's and a Yuasa). Last one was the same PC680 (without the metal jacket as it wouldn't fit in that one) and it still was going strong after 5 years when I traded it on the GT.

It gets really hot where I live, often 105+ degrees. I suspect it just kills the batteries around here and sitting on top of, or behind as on the RT, engine just doesn't help with regards to their life expectancy.


Mack
 

·
Registered
Joined
·
121 Posts
++1

I just put an Odyssey in because I had slow cranking issue that really bugged me. The Odyssey is great! Just a touch of the starter and I am off and running. I totally recommend it.
 

·
Registered
Joined
·
121 Posts
++1

I just put an Odyssey in because I had slow cranking issue that really bugged me. The Odyssey is great! Just a touch of the starter and I am off and running. I totally recommend it.
 

·
Registered
Joined
·
623 Posts
Odyssey here too.

Even after the BMW dealer tried to kill it when they direct wired the Autocom to it and it drained it down in three weeks. They blamed me for NOT keeping the bike on a trickle charge.
It recharged and has been fine.
 
1 - 10 of 10 Posts
Top