BMW K1200, K1300, and K1600 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi
Has anyone experienced the adjustable screen not working on a K1200GT ...My 2006 GT screen is not adjusting... a feint sound can be heard when the button is pressed either way but nothing happens..I have taken out the mechanism and can confirm the there are no siezed components and when 12v is brought to the motor it works perfectly...this would lead one to suspect the switch or wiring..or possibly the ZFE unit....However my dealer tells me that the switch is ok...would it be possible that the system just need re-setting with a GS 911 ?..
 

·
Registered
Joined
·
357 Posts
Yes, the 911 can now reset and calibrate the screen travel. Whether or not it fixes your issue remains to be seen.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Went and purchased the GS 911 today... when i checked i found the following error present;

41765: Windscreen / Spring strut adjustment malfunction, open-circuit
The fault is currently present. Also when I try and calibrate the screen it proceeds to about 90% complete then aborts with a message stating that an error occured during calibration :dunno:
Anyone got any ideas ??
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Electric Screen Not Working

Hi Guys
Electric Screen now working

Sourced a ZFE with the same part number which incidently came out of an R1200RT !
Fitted same and calibrated the screen travel on my GS 911 and Happy Days!!
Henry :)
 
1 - 4 of 4 Posts
Top