BMW K1200, K1300, and K1600 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
What started as an intermittent event has become a permanent state on my 2007 K1200S.

discussion with dealer, 60 miles away, reveals the following;
  • the ring antenna was replaced in 2008 with new improved unit. Was not part of recall
  • they have experienced issue of this sort with bikes having Li-ion batteries.

I installed a Shoari in May of last year.
No issues of any sort, until now.

Gs-911 indicates Immobilizer issue, non specific. Battery voltage of 13.57
no battery issues noted by GS-911

will be using MOA premium membership towing feature on Tuesday

Anybody have similar experience?
 

·
Registered
2009 K1300S, 2017 S1000R
Joined
·
619 Posts
A good possibility is your right side switch module. They were recalled. Do you have the latest? Not hard to change but you do need to find instructions and get the correct small torx driver for the screws. I believe it is a #9 and fits very snug. 8 works but do not strip it or serious trouble happens. So get a set of small drivers and check it out if you do this job. It may even be free at the dealer if you ask. It was a recall.
Other things are broken wires and even a bad antenna ring as no part is perfect. Stuff like this is a serious pain, sorry, keep in mind 60% of electrical problems are battery related. I know the cool and latest thing is the lithium batteries but the bike charging system is not designed for them.
 
1 - 3 of 3 Posts
Top