BMW K1200, K1300, and K1600 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have just joined the K family with a 2007 K1200S. I hate to ask a question that may have many answers already, but I can't find it so far. My fuel gauge reads zero and there is a caution in the display. I have found a little on the "fuel strip" but I cannot get details on what it is or how to fix the problem. I gather that it is a capacitance type sending unit so will a float type work with the factory gauge?
Any help appreciated.
 

·
Registered
Joined
·
478 Posts
Have you local Beemer shop replace it. Know fault. It might also be a recall item at no charge, or not
 

·
Registered
Joined
·
1 Posts
I did receive notice a few months back about a recall on the fuel indicators failing. I don't have my paper work in front of me, but the dealer should know about.
 

·
Registered
Joined
·
71 Posts
Mine reads full to half. Half is flat empty, but I know I can go 200 miles and use the trip meter like the old days if I get close. One of these days I may get it replaced, then again my tank is always half full
 

·
Registered
Joined
·
166 Posts
There's definitely a TSB on the fuel strip and i think they're covering them without question at this point. My paperwork is also at home but I would phone your local BMW shop and talk to them...

So far I've only needed one on my 2008 K12GT.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Thank You

Thanks for the info guys. I'll see if the dealer will replace it. I would just buy one and install it at sub $200 but I have also heard of off the shelf units not working. I am getting used to filling up at the 150 mark because I costed into a station with 177 on the odometer and don't want to temp fate. :(
 
1 - 7 of 7 Posts
Top