BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
I'm posting for a riding friend who is "computer xxxxxxx"........anyway, a new K1200GT with about 800miles and he loves it; after seat adjustments......

When returning home from WA rally, the power assist on the brakes "went out".......we stopped at gas station....talked about the failure...then he started it up, and they worked again.....

Any info on this??? The parts manager at the dealer who has a K1200S said it happened to him a couple of times; BMW regional rep knows nothing about a problem....but will check......
 

·
Registered
Joined
·
56 Posts
Discussion Starter #2
brake failure...also

Also, forgot to mention that he did not notice and warning lights on dash.....
 

·
Registered
Joined
·
68 Posts
well.....
we'll have to see what this means.... brake failures a couple of years ago were ALL THE RAGE on bmw forums throughout the world
but..... for now, i guess this is at least one reason i can be happy that i'm getting a 2007 bike without power assist.
but..... a BRAND NEW brake system for BMW doesn't instill confidence in me, either
 

·
Registered
Joined
·
24 Posts
Mine failed at 1500miles. Brake failure lights and no power assistance.

At first BMW said just bleed the brakes. The garage did this but the brakes failed again.

Eventually they replaced the brake pump.

Very scary when they go. The residual braking is better than the 1200RT but pretty useless with a pillion.

I am not happy especially when I hear that next years bike will have a new system. Does this mean I will be left with an inferior lemon?

Tom
 

·
Registered
Joined
·
56 Posts
Discussion Starter #5
thanks for the info.........Gary said he definitely had no dash light indications....I'll tell him about it......
 
1 - 5 of 5 Posts
Top