BMW K1200, K1300, and K1600 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've had this problem a couple of times now, my heated grips won't switch off. One (right hand) needs changing as its stopped working. Has anyone had this before, is there a separate controller box for the grips somewhere?

2011 K1300 GT EE.


Mike
 

·
Registered
Joined
·
677 Posts
The heated grips, like most of the electrical accessories, are controlled by the ZFE module, which is located on the forward right hand side of the bike under the big side panel. A good plan might be to get access to a GS 911 diagnostic tools to see if any error codes have been generated. It could be a short circuit in a switch, any of the wiring between the components, or a failure of the actual ZFE itself.

If you have a known bad heated grip, and that is because of an open or short circuit, the ZFE may not be able to control the circuit. Good luck.
 
  • Like
Reactions: Rager

·
Registered
Joined
·
68 Posts
FWiW some bits of the system is sort of self-healing, Instead of a battery backup they must use caps. I'm guessing that shutting a failing operation off and then back on reboots it.

Today my cruise control started getting wonky from (?) over use?

I shut the entire cruise off and then back on and seemed to bring all of it back. No sweat.

Cool is dialing the twist OFF (throttle OFF) shuts off the cruise control like grabbing a brake or moving the set paddle OFF.

Sometimes the set paddle doesn't turn the cruise off, no problem for me. There are redundancies.
 
1 - 3 of 3 Posts
Top