BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Anyone notice grips warming up when ignition turned on (even if motor not running)? It could be 95 degrees outside and they will still go on - not sure how long they stay on, but it seems like after a while either I stop noticing, or they go off. The hand grip switch is in the 'off' position when this happens.
 

·
Registered
Joined
·
497 Posts
You know, I thought I have noticed this as well. But I tend to run pretty warm, so I just thought it was me. Then the other day my Dad put his hands on the grip after I was riding and asked if I had them on.

Strange :wtf

Brian
 

·
Registered
Joined
·
236 Posts
Notice almost every time I start the GT. Then again, I first noticed it on my KS. On both bikes the switch is always off, however, the grips fill like they are warming up. Seems to go away after a while. Thought it was my imagination. Guess not! Perhaps there is medication for this illness. No?
 

·
Registered
Joined
·
232 Posts
Darn, I thought it was my imagination! I'm going to set up a digital thermometer to verify this. Wonder if V 7.0 fixes this too :rolleyes: ?
Greg
 

·
Registered
Joined
·
838 Posts
I've noticed this as well. In fact, I've noticed the same thing with the heated seat. However, rather than an electrical gremlin, I've concluded I only notice it after the bike has been outside, parked in the sun. I'm convinced it is only thermal energy absorbed by the black component. I never notice this when the bike has been parked in the garage.
 
1 - 5 of 5 Posts
Top