BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi there, new to the site and fairly new to owning a 06 k12gt.

I was riding the other day in heavy traffic and quite hot weather. Rare in the uk!
Due to the traffic I did a lot of filtering. Dragging the rear brake a bit too much.
Then the red warning triangle came on and the brake failure light started flashing. This was also along with loosing any servo assistance to the rear brake.
I switched off and re started and issue went away for about 10 minutes and then came back.
Have just fitted a new higher rated battery to the bike and new pads were fitted prior to me purchasing. Have ridden about a month prior with no issues.

The research have done online leads to either a possible abs pump issue or battery issue.

Does anyone have experience of this or have any ideas

Cheers
 

·
Registered
Joined
·
478 Posts
I feel for you brother. I sold my 06 GT with exactly the same issues. Wasn't the battery, that damn servo pump was going. If you have a Gel battery, get rid of it and get a AGM battery. Go to I- BMW site to read possible solutions. There is a US company Module Masters that is now rebuilding your ABS pump for one third the price of a new one from BMW. Good luck.
 

·
Registered
Joined
·
357 Posts
Did the 06s have the servo assisted brakes? (You pull the brake lever and you can hear all sorts of whining and whizzing?)
There is a difference between the ABS pump and servo brake pump. When the ABS pump goes you get the constant Brake Failure light on steadily, no flashing.
.
.
.
Well, after some research I'm a bit puzzled. Various write-ups mention the servo brakes in all 3 years 06-07-08. I have an 08 and it definitely does not have the servo system. I know this because it would have convoluted things when the ABS module crapped out. Anyone know if they deleted them mid model year of 08?
 

·
Registered
Joined
·
357 Posts
aj7840 said:
The servo brakes are only the 06 K1200GT gen 2.

The 07's on do not have the servo brakes
Tks!
 
1 - 5 of 5 Posts
Top