BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter #1
I am back on my bike :) didn't ride it for 5 1/2 months due to a health issue, its a bitch to ride with your right ankle in a cast and then after the cast when you can't put weight on your right foot! But I rode to work today, bike was a dream to be on again at last.

A few questions, when I put the bike away it had the service light on since it was coming on being due for a oil change. I never disconnected the battery and had it on a charger most of the time bike was not being used so the battery never died, but the service light is off now. Does the service light go off after some months past the due date ? I didn't think it did.

I am now way overdue for a oil change of course, even though the current oil only has about 3,500 miles on it, its over a year old, I am thinking of doing my own oil changes from now on. I was looking at Beemer Boneyard and I like their kit with oil included, one easy order and get everything at once. Think I will go with 10-40 fully synthetic, including full synth for the final drive, any reason to go with 5-40 OR semi-synth ? I don't know what the dealer has been putting in the bike all these years, didn't really care at the time, I just took it to them twice a year for oil changes, but its time to do my own work on it.

Any reason to spend more money on a wifi GS911 ? The only reason I see is that it will work with my iPhone on the road in "emergency" mode though I am not sure what that means. With the cheaper USB one, I am stuck to working in the garage as I never take my laptop on the road with me (I try to disconnect when on the road, even though I do have my iPhone with me). I figure I will need the GS911 at a minimum to reset service reminders, but I am sure it will be handy.

This weekend, I am going to remove the fairing and see if I can clean the throttle bodies, I noticed before I stopped riding that my bike was having a "stumble" around 2,500-3-000 RPM when I grabbed the throttle, for example coming off the freeway, if I decided to accelerate as I was decelerating, it would hesitate a little. I am guessing its a dirty throttle body based on reading other posts here, the bike has NEVER stalled even when new and also did not use to do this either. I had planned on doing it while in the cast but I was always going to do it next weekend and that never came, now that I am riding again, time has come.

Tires were low on pressure (as expected) but the bike started right up even on the 6 month old gas and didn't skip a beat, the only thing wrong was the time on the clock was almost 15 minutes fast (or 45 minutes slow and I am not accounting for the time change :) )
 

·
Addict-oholic
Joined
·
1,416 Posts
Before you clean the throttle bodies, buy some fuel system cleaner such as Techron ( bought at any automotive supply) or BMW ( uses the same chemicals). Put in a double or triple dose in the tank for the first go around, Then use the recommended dosage each subsequent tankful. My dealer told me this when I was having the exact same problem. Mine went away with this program.
If it works, go no further. Then you can clean the throttle bodies if you are still having the problem.
 

·
Registered
Joined
·
163 Posts
Discussion Starter #3
hmm, I have ALWAYS run Chevron gas on my bike since day one and it has Techron in it, but I will try that first anyway.
 

·
Registered
Joined
·
365 Posts
not sure if you have the k12 or k13.

The k12 was notorious for a flat spot accelerating from between 2500 and 3000 rpm, the cure was a power commander, Powerfreak or one of a multitude of aftermarket units to correct the fueling problem at that RPM.
 

·
Registered
Joined
·
163 Posts
Discussion Starter #5
Sorry, 09 K13GT

I put the Techron in last week but so far no change, however I only put 150 miles on it over the weekend so I really was not expecting a change that fast.
 
1 - 5 of 5 Posts
Top