BMW K1200, K1300, and K1600 Forum banner

1 - 6 of 6 Posts

Registered
Joined
15 Posts
Discussion Starter #1
Posted last year about infrequent engine cut out. Had my 2000 K1200RS since 2002, done 63000 miles. Riding until fuel stop, fill up, about 20 miles later all dash lights illuminate and engine cuts out and stalls. If I switch the ignition off and start up it the goes fine. Just happened 3 times on a 2000 mile tour of Spain and France; thought it was sorted but isn't. Fitted new battery, fuel filter and isolated the kill switch. Someone please give me the simple solution to this ongoing 2 year problem; you will forever be my hero馃弽馃槉
 

Registered
Joined
15 Posts
Discussion Starter #2
No solutions so it's off to a BMW specialist to be 'Moditec'd. Will post the findings here. Maybe something to do with the vacuum intakes? We'll see.
 

Registered
Joined
15 Posts
Discussion Starter #3
Now solved thanks to Paul Fennel at The Workshop, Upper Poppleton, York. It was a cracked crankcase breather tube. Bike now runs like new; brilliant result. Giveaway is the oil leak it gives around the throttle bodies.
 

Registered
Joined
15 Posts
Discussion Starter #4
Now solved thanks to Paul Fennel at The Workshop, Upper Poppleton, York. It was a cracked crankcase breather tube. Bike now runs like new; brilliant result. Giveaway is the oil leak it gives around the throttle bodies.
So after 1400 miles through the UK, Northern Spain and France this happens again, engine cuts out. Latest step to cure is the replacement of the ignition key to wiring harness wiring; fingers crossed. Full electrical check by auto electrician reveals no other problems as did the diagnostic.
 

Registered
Joined
1,791 Posts

Registered
Joined
11 Posts
Get them to replace the wiring harness. I had an intermittent problem with my '98 K12 where the bike would just die. After many trips to the dealer, new moronic, O2 sensor, etc. it stranded the dealer on the road when doing a test ride. Full new harness after that. Fixed.
 
1 - 6 of 6 Posts
Top