BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Had my trusty stead for 15 years and really want to keep it. It's done 59 000 miles. Recently had an intermittent cut out problem. A couple of times stationary at start up it has ticked over then suddenly the fuel warning light comes on and it cuts out. The bike then starts and runs well.

It's also infrequently done this in general riding and cruising; fuel light on then sometimes a stall with all warning lights, engine then continues.

Thought it was the 'floppy' kill switch but this has been isolated, so that's not the problem.

Fuel filter changed in 2009. Ideas anyone? Help would de appreciated. Thanks.
 

·
Registered
Joined
·
137 Posts
will take a stab... have you checked your fuel line inside tank in case it has a split? Been known to cause similar cut-out issues before... reported more on the LT list than I've seen in other forums, but its the same system. good luck hunting down the problem.
 

·
Registered
Joined
·
6 Posts
Had my trusty stead for 15 years and really want to keep it. It's done 59 000 miles. Recently had an intermittent cut out problem. A couple of times stationary at start up it has ticked over then suddenly the fuel warning light comes on and it cuts out. The bike then starts and runs well.

It's also infrequently done this in general riding and cruising; fuel light on then sometimes a stall with all warning lights, engine then continues.

Thought it was the 'floppy' kill switch but this has been isolated, so that's not the problem.

Fuel filter changed in 2009. Ideas anyone? Help would de appreciated. Thanks.
K1300 stalling every corner when i stop so, i remove gas tank and check for the actuator or iac valve under the airbox. I remove it and i notice it was full of crap! I clean it very well so i clean the hole where it goes instaled and HELL yeah!!! It worked. This failure was not detected using gs911. Idle now is soo smooth every red light.
 

·
Registered
Joined
·
86 Posts
Had my trusty stead for 15 years and really want to keep it. It's done 59 000 miles. Recently had an intermittent cut out problem. A couple of times stationary at start up it has ticked over then suddenly the fuel warning light comes on and it cuts out. The bike then starts and runs well.

It's also infrequently done this in general riding and cruising; fuel light on then sometimes a stall with all warning lights, engine then continues.

Thought it was the 'floppy' kill switch but this has been isolated, so that's not the problem.

Fuel filter changed in 2009. Ideas anyone? Help would de appreciated. Thanks.
Hi

Have you checked the vent line, which is a small hole inside the filler cap aperture? Mine was blocked and caused a vacuum which was enough to stall the engine!
When I opened the filler cap, there was a whooshing noise.
I did not have any fuel light issues, however the fuel gauge stopped working because the fuel sensor housing deformed as a result of the vacuum, this stopped the float from moving up or down.
I cleaned the line using wd40, the inside of a bike brake cable and some strimmer wire.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5 (Edited)
Thanks for the above guys. This has been a couple of problems. Firstly the kill switch was loose this has been isolated. Secondly as identified above there was a venting problem. The internal top tank vent pipes were ok but the g clips were not tight, I replaced them with jubilee clips: the two internal pipes to the top tank vent need to be replaced on the correct feed, as I found out fuel vents from one pipe at standstill when you switch the engine off otherwise. Bike runs beautifully now, as it always has. Thanks for pointing me in the right direction.
 
1 - 5 of 5 Posts
Top