BMW K1200, K1300, and K1600 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 2009 k1300gt windscreen is acting up. Sometimes it works, sometimes it doesn't. Can't find anything obvious at the handlebars. Took off the windscreen and motor cover and fiddled with the wires going into the motor. Anybody had a simular problem?
 

·
Registered
Joined
·
161 Posts
Did you buy a red K13one back from Jacob T? Almost bought it, sorry I hesitated just a few days too long.

First and always, have you used the search function on this or other sites?

Handlebar switches can be problematic. There are several things you could try, but generally you want to discern whether it's the switch, the motor, windshield mechanical linkage, or "something else".

Does the shield go up and down smoothly, when it works? If so we can omit further consideration of the mechanical linkage. You could also disengage it from the motor to confirm smooth operation.

To check the switch, can you put a test light or multimeter on the wires from switch to motor and see (when the shield isn't working) whether the switch is sending power to the motor? That would confirm or exonerate the switch.

To test the motor... whack it when it doesn't want to behave and see if it responds then. If it's the motor that is cranky, disassembly or replacement would seem to be your only options. How are your mechanical skills?

You could just live with it. Worse things have happened to Kbike owners. IIRC (and if this is the bike I rode) the shield is aftermarket and larger than stock. Was it correctly installed or somehow subject to jamming. Worked when I rode it. Can't be more than one K13gt in Pahoa nor likely others in all Hawaii.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Windscreen

Yeah on several accounts. This is the bike Jacob had. I had been talking to him for months, but not too seriously. Then my K1200s tried to seize, and he dropped the price at the same time. Got to rebuild the bottom end of the S bike, or sell it to someone that has hit a tree with theirs. Got a '01 R1100R that needs to be sold if you know of anyone. Runs perfectly.

I understand the process of elimination to find the problem. Right now I need to figure out how to remove the switch from the handlebar. Thought someone that had experienced the same thing could point in the right direction and save some time.
 
1 - 3 of 3 Posts
Top