BMW K1200, K1300, and K1600 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Also posted this in the maintance forum, but hoping for an answer from this forum as well.

Today I fullfilled a dream. I bought a 85 K100RT from a buddy. I have discovered something that my buddy did not know..

It appears that the brake light is stuck in the "on" position. I checked the bulb and it is VERY bright and does not appear to be a double fillament bulb, next I checked the obvious with the switches on the front and rear brake, neither are sticking and appear to be clean...

What should I do??? I have this gorgeous new bike and cant ride it because I have no brake lights!!!!

HELP!!

Thanks, Tim

PS, can anyone advise the bulb # that should be in there? there are two differant ones, one is the licence plate light and the other is the brake light.

Thanks!
 

·
Registered
Joined
·
504 Posts
Bowcop said:
I checked the bulb and it is VERY bright and does not appear to be a double fillament bulb…
My 87 K100RS had a dual element bulb there. I do know you can get a single element bulb (an 1156) into the socket, which by design will light brightly as the single contact will receive current from BOTH contacts in the OEM socket. AFAIK, 1157 is the bulb. Bulbs HTH.
 

·
"Hey Y'all"
Joined
·
2,239 Posts
Tip of the day ...

Bowcop said:
Also posted this in the maintance forum, .........
See my light reply in your original Brake light problem post.

**************
For future reference, it might be best to post in one location and just "link" the second post. That way everyone is answering in the same place. Just post, submit, and copy the url address. Place the url in you "second" post.

If I still had my cape on I'd throw in that I think it's fine to double post urgent matters, but still - use the link method. But forget that I said that ....


p.s. Dang, I plumb forgot..... Welcome !!
 
1 - 4 of 4 Posts
Top