BMW K1200, K1300, and K1600 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi folks, I'm new on here and in desperate help. I have a 05 k1200s where the dreaded brake failure light is going flashing mad and after flashing for 10 minute's braking disappears completley making for an interesting ride with no brakes. I'm guessing the abs is knackered and need of repair. Need these questions answering.

1, how hard is it to remove pump from bike.
2, once pump off can brakes be bled as normal or does it need diagnostic to pull fluid through.
3, I see a lot of talk of bypassing pump. How is this done. Has anyone got an idiot's guide. I'm quite happy to have no abs. Is there a plumbing kit for thus?
4, I need this done on a budget and do it myself. I can get pump rebuilt for £200.

Any knowledge would be appreciated!

Regards

Bryn
 

·
Registered
2009 K1300S, 2017 S1000R
Joined
·
291 Posts
There is no cheap fix for this except bypassing the unit. The're threads on this if you search. You can not bleed the systems if it is not all sealed up. Either via a by pass or the ABS unit. There is a company in the UK that repairs them if you search, maybe on the UK forum for K bikes. There is a German company that repairs them for about $800 USD. They have a by pass plate for the same money. You have to have the ABS electronics to keep things working in the brake light and speedo department. Maybe someone who has done the job will chip in with some help.
I did an "advanced search" on this forum and there is lots to help you.
Check this: https://www.k-bikes.com/forums/search.php?searchid=461369
 
1 - 4 of 4 Posts
Top