BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, I need some advice. My 2010 K1300S has 72000KM and I love the bike and had no issues. Then last month my quick shifter started to fail 80% of the time. Ok so I shifted manually. Then on same day, as I go up the gears the engine would cut out as I accelerated (note never stalls on idle) . This just got worse over the last few rides and the strange thing is that its ok in 6th gear (link to shifter ??). It happens all over the RPM range, just cuts out/bucks for a half a second - then on - then bucks and then runs ok for a few minutes. Very annoying. I thought it could be the gas, but I have filled the tank a few times already with the highest octane. I thought maybe the plugs, but I don't see / shake when I idle it or rev it in neutral. All well in 6th but i cant drive it like this. Any help would be appreciated.
 

·
Registered
Joined
·
82 Posts
Remove the quickshifter unit/rod and run the engine. Now shake the quickshifter.

If it cuts out, then the little magnet inside the shifter has fallen out of the plastic piece holding it in place.

The aluminum housing is screwed together with loctite. A heat gun and spanner will open it though. Be carefull, there is a spring inside.
 

·
Registered
Joined
·
42 Posts
Or, if you haven’t looked already, a new quick shifter costs $600 - $650 . If the repair fails, I’d disconnect it and keep an eye on ebay and Beemer Boneyard for a used one. Hoping, of course you don’t buy another broken shifter. Hope you get it sorted out.
 

·
Registered
2009 K1300S, 2017 S1000R
Joined
·
588 Posts
In the mean time you could buy two ball joint ends and some 6mm rod and make a solid one so you can keep riding.
 

·
Registered
Joined
·
42 Posts
I wouldn’t look for the rod and ball joint ends at your dealer. BMW thinks those three items are worth over $55.00, but Max BMW does throw in a couple of stickers and a bag of M&Ms to “sweeten” the deal.
 
1 - 5 of 5 Posts
Top