BMW K1200, K1300, and K1600 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hi All , as I'm back in the saddle again, i have purchased a 94 K75 rt and may i say what a little beauty. My question is about the heated grips as mine are not working too good, what do i look for and how are the heated, is there a unit hidden away some where, your help would be appreciated
:boom:
 

·
Registered
Joined
·
129 Posts
Not good?

How are they not good? Do they heat at all?

A common problem is the throttle side where the wires fatigue and break due to movement.

They are just a heating wire wrapped around the bars under the grip and on the throttle tube. there is not another component other than the wiring, connectors and switch.

if it's heating at all, you could check all the connections to make sure they are not corroded in some way and disassemble the switch (carefully in a plastic bag to avoid losing parts) and give the contacts a good clean.

If one or the other is not heating, I'd start looking at the wiring.

TG
 

·
Registered
Joined
·
1,791 Posts
I don't have the specs off the top of my head, but the switch controls the voltage. Full voltage on HI and then less on LO. If one isn't working at all, then you may have a broken wire/element under the grip. That can be fixed once you peel the grip off if that's what it is.

Get the meter out and do some output tests after the switch.There should be a connector between the switch and grips.
 
1 - 3 of 3 Posts
Top