BMW K1200, K1300, and K1600 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1
Does anyone have this and if so how accurate is the temperature. I have been putting up with this being 10 degrees off all summer and now it flashes the ICE warning when it is ten degrees from freezing. Talked with the tech at Kisan and he explained how to set the pot to get it corrected and I got it all set up and thought I had it and two days later and it is 6 degrees off again. I am tempted to purchase another sending unit from Kisan but wanted to know if anyone had a good one before I went through the expense.
 

·
Registered
Joined
·
1,790 Posts
Not so long ago I was singing the praises of their service. But now I'm not so sure. I talked to Andy last week and he told me to turn the sending unit over so water wouldn't stay in it. Have had numerous problems with the shunt and they have sent new better ones. Have had it for two years and it has never worked right. Now he says that seven degrees is acceptable. I bought it mostly for the Amp/Volt meter and installed it on my Tiger so I wouldn't kill the battery when running the Gerbings in the cold weather. The ICE flashing is a major distraction!
Shall we gang up on them????
 

·
Registered
Joined
·
146 Posts
Discussion Starter #3
I talked to Andy last week that is when he told me that there is a small pot that you can adjust well I adjusted the crap out of that thing and it WILL NOT give a correct reading it fluctuates and reads all over the place I am going to adjust it once again so that the temp reads high instead of low so I dont have ice flashing when it is 40 degrees out. It seams to be a pretty good Amp/Volt meter but now I am wondering what the tolerances are on that also.(7 degrees is pitiful.)


I think we need more than two for a gang.
 

·
Registered
Joined
·
1,163 Posts
bmwriders said:
Does anyone have this and if so how accurate is the temperature. I have been putting up with this being 10 degrees off all summer and now it flashes the ICE warning when it is ten degrees from freezing. Talked with the tech at Kisan and he explained how to set the pot to get it corrected and I got it all set up and thought I had it and two days later and it is 6 degrees off again. I am tempted to purchase another sending unit from Kisan but wanted to know if anyone had a good one before I went through the expense.
I have an ambient temp gauge, can be seen on a post I did re GPS. Cheap as dirt , tells you the temp fine, wont flash though.
 
1 - 4 of 4 Posts
Top