BMW K1200, K1300, and K1600 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
Ive had my Nav IV(Zumo 660) a few months now and although Its quite an impressive bit of kit I still find it slow to redraw maps and it has a couple of times took me down ridiculous back routes even though I have the preferances set up to avoid unpaved roads.

Now, what I have found and Im asking you guys if this is normal is, if I log in to "my garmin.com" and look at installed maps, it says I have 2 different maps installed:
City Navigator Europe NT 2012.10 - Map+2D+P+3DB, Apr 11 and
City Navigator Europe NT 2013.20 - Map+P+3D, July 12

and yet on the device itself If I look at maps installed its as the screenshot below, spot the difference?



Any thoughts welcome, cheers
 

·
Registered
Joined
·
33 Posts
Special-K said:
Ive had my Nav IV(Zumo 660) a few months now and although Its quite an impressive bit of kit I still find it slow to redraw maps and it has a couple of times took me down ridiculous back routes even though I have the preferances set up to avoid unpaved roads.

Now, what I have found and Im asking you guys if this is normal is, if I log in to "my garmin.com" and look at installed maps, it says I have 2 different maps installed:
City Navigator Europe NT 2012.10 - Map+2D+P+3DB, Apr 11 and
City Navigator Europe NT 2013.20 - Map+P+3D, July 12

and yet on the device itself If I look at maps installed its as the screenshot below, spot the difference?



Any thoughts welcome, cheers
Perfectly normal - my Zumo has the exact same maps installed.. and looking at My Garmin - I see a very similar old version there - My guess is that the new maps are a partial update. by which I mean.. just new data added to the previous version - which is still there just renamed and with new roads.. junctions and so on - added.
 
1 - 3 of 3 Posts
Top