BMW K1200, K1300, and K1600 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
my 2010 k1300gt has developed an annoying glitch.. on decel in gear the rpm wants to hang up @ 2000 rpm,, pull in the clutch and idle drop s to normal. does it in all gears.. throttle cables not binding, cruise not engaged and completely off. as rpm approaches 2k, exhaust burbles and rpm want s to surge slightly,, booster and o2 sensor mod kit no help...only mod is a remus can,but bike didn't do this til about 36k miles, remus has been on since 5k..going nuts trying to find problem, any help greatly appreciated... :confused:
 

·
IBR# 366
Joined
·
3,145 Posts
There were some early issues with the air box idle valve sticking on the K12GT bikes, but they had that sorted by the K13 bikes.

Some K13 bikes had the hanging idle issues as you described. I believe it was a software fix for those, rather than a hardware issue. Might be worth letting your dealer hook the bike up to his computer and make sure you've got all the latest software installed.
 

·
Addict-oholic
Joined
·
1,416 Posts
I had a similar issue with my 2009 1300Gt. When decelerating (usually after the bike is warmed up). and shifting into 1st, the bike hesitates at 2000rpm and then dies. I was on one ride with the owner of Cliffs ( before it became Max). he explored the issue and it was a software upgrade and regular cleaning of the throttle bodies with Techron in the gas every few tankful's and a biannually manual cleaning. Bike runs like new.
 
1 - 3 of 3 Posts
Top