BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
764 Posts
Discussion Starter #1
When stopped at traffic lights, my speedo claims I'm going between 18 to 28 mph. If I pull in the clutch and rev a bit, it steadies. Putting on the brake makes it more erratic.

At first this misbehavior happened only when the bike was first cranked for the day. After lying for awhile (about a block), it told the truth for the rest of the ride. But recently it's gotten worse and now lies all the time at idle. On the highway, speedo indicates same as GPS.

I remember this being discussed a long time ago, but don't remember what cause was found. Does anybody know what causes this and what to do about it? :confused:
 

·
Registered
Joined
·
1,047 Posts
allenclarkson said:
When stopped at traffic lights, my speedo claims I'm going between 18 to 28 mph. If I pull in the clutch and rev a bit, it steadies. Putting on the brake makes it more erratic.

At first this misbehavior happened only when the bike was first cranked for the day. After lying for awhile (about a block), it told the truth for the rest of the ride. But recently it's gotten worse and now lies all the time at idle. On the highway, speedo indicates same as GPS.

I remember this being discussed a long time ago, but don't remember what cause was found. Does anybody know what causes this and what to do about it? :confused:
Allen: I found the thread:
http://www.k-bikes.com/ubbthreads/showthreaded.php?Cat=&Board=technical&Number=39419&page=&view=&sb=&o=
Mark
 

·
Registered
Joined
·
23 Posts
When I was having trouble with the brakes on my 02 KRS the speedo would occasionally climb while standing still when the front brake lever was pulled. Since I had the servo unit replaced it hasn't done it.
 

·
Registered
Joined
·
764 Posts
Discussion Starter #4
mbohn said:
Thanks for finding it - I could have looked harder.

The only concrete thing there was Bear's report on a problem with the pickup in the final drive. Getting that right fixed his problem, but it can't be what's wrong with my bike.

Tony Beattie (Serv Mgr at Max BMW) says he's seen it only once before - on a new LT. When he couldn't get that bike to do right and asked BMW for help, they said it was something being worked on in Germany - i.e., a known problem with no solution yet. But if that's so (certain that's what BMW told Tony), I am surprised it hasn't been discussed here more than what was in that thread.

Had forgotten how your Speedo kept moving :D - she musta looked pretty sharp ;)
 

·
Registered
Joined
·
41 Posts
My cluster was swapped with a known stable one by an NY dealer while on the road. The new speedo does not wander while idling.
 
1 - 5 of 5 Posts
Top