BMW K1200, K1300, and K1600 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
When my 03GT which I just purchased sits for more than 3 days, the starter will not turn over. Lights look bright. Checked the battery (05 exide gel) and found that when charge is 12.5 volts it will start, but when it drops to 12.0 it will not. Just a minute on the charger and it starts right up. Any suggestions?
 

·
Registered
Joined
·
629 Posts
Your battery is toast unless you can charge it and it can read 13.4-13.6 volts on it's own.

Are you locking the handlebar? That cuts off all power. if you leave it unlocked, you might have parasitic drain.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
starting

I have not been locking the handlelbar, but I will start doing so. I removed the battery and put a charger on it. It would get up to 14 v. and then I could take the charger off and with voltmeter see charge drop back down to about 12.5. Guess the battery has a problem. I plan on putting in an Odyssey 680. Had one on my RT and no problems.
 

·
Registered
Joined
·
264 Posts
djhdjh said:
I have not been locking the handlelbar, but I will start doing so. I removed the battery and put a charger on it. It would get up to 14 v. and then I could take the charger off and with voltmeter see charge drop back down to about 12.5. Guess the battery has a problem. I plan on putting in an Odyssey 680. Had one on my RT and no problems.

Good plan. I agree it is a battery problem and use/like the pc 680 a lot. --Jerry
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Odyssey

Just an update. Dropped in an Odyssey 680 last night. Measured 12.85V . When running measures 13.4V, so charging system is ok. Straight drop in replacement, just needed to bend the connectors a bit.
 
1 - 6 of 6 Posts
Top