BMW K1200, K1300, and K1600 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hi All,

My 08 12GT throttle operation is screwed up. when you open the throttle it stops at the half way point. You can force it over the hump to full throttle but when you go all the way to idle, it will hang up again when trying to open. If you force it over the hump and just move it a little over the spot it sticks at, it will move semi freely but you can tell there is something interfering with the throttle. The problem is located down on the throttle body, I have the tank off. But I can't see where it is hanging up. all the springs look like they are in the right place. Anyone see this before? easy fix?
 

·
Registered
Joined
·
161 Posts
First question I'd ask is: did you mess with it? If so, go back and put it together correctly, whatever that may be.

Second, is something hanging up on the exposed cable linkage? You'll have to get in there and check the end of the cable at the throttle bodies.

Third, you could have kinked the Bowden cable sheath and/or the cable itself. One way to test might be to disconnect at the throttle body end and see if the resistance is still there.

Fourth, could be something hanging up the throttle linkage on the throttle bodies themselves, possibly if you "did something" in the vicinity.

Lotsa luck, my older K-bike has the same problem...
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
It sat for 8 months and was fine when I parked it, not messed with. I have the tank off and you can tell it is hanging at the pulley on the throttle body, I just can't tell were.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #4
Well, I got the tank back on (I was changing the fuel pump), started the bike and the throttle is now free... Go figure...
 
1 - 4 of 4 Posts
Top